aigoncharov Github contribution chart
aigoncharov Github Stats
aigoncharov Most Used Languages

Activity

22 Nov 2022

Aigoncharov

started

Started On 22 Nov 2022 at 10:11:20

Aigoncharov

update post: Getting a talent visa in the UK for mortals

Pushed On 16 Nov 2022 at 11:38:43

Aigoncharov

Update README.md

Pushed On 04 Nov 2022 at 10:25:13
Issue Comment

Aigoncharov

Devtools not showing on Linux

🐛 Bug Report

I downloaded the latest (0.173.0) version of flipper from the website. While trying to troubleshoot another problem, I found I'm unable to open the devtools via `View->Tggle Developer Tools". Instead, an error is logger to the console (linux terminal) saying:

"[73555:1029/171526.903093:ERROR:CONSOLE(1)] "Uncaught Error: Missing actionRegistry for shortcutRegistry", source: devtools://devtools/bundled/ui/legacy/legacy.js (1)"

Let me know if you can't reproduce or need additional information.

(In case it's relevant, since googling that bug brought me to some electron-related pages: my electron version is 20.0.3-3)

Forked On 02 Nov 2022 at 11:51:10

Aigoncharov

@ldorigo what are your system details? It works for me on Ubuntu 22.04

Commented On 02 Nov 2022 at 11:51:10
Issue Comment

Aigoncharov

The native module for Flipper seems unavailable.

🐛 Bug Report

After installing, v 0.171.1, got a warning message "The native module for Flipper seems unavailable. Please verify that react-native-flipper is installed as yarn dependency to your project and, for iOS, that pod install is run in the ios directory." Flipper plugins are not working anymore, downgrade react-native-flipper version to 0.162.0 fix the issue but disabled updates for newest versions.

To Reproduce

  1. Create RN project
  2. yarn add react-native-flipper
  3. Install "redux-debugger" plugin for example
  4. Launch app on iOS (simulator or device) and Flipper 0.171.1
  5. Flipper plugins don't work

Environment

Flipper desktop: 0.171.1 RN 0.68.2 react-native-flipper 0.171.1 redux-flipper 2.0.1

Forked On 25 Oct 2022 at 08:47:53

Aigoncharov

Quoting #4265: Resolving https://github.com/facebook/flipper/issues/3859 led to breaking changes in react-native-flipper which made it incompatible with react-natvie < 0.69.

As a result, we had to make a hard decision of supporting future react-native-flipper updates only for react-native 0.69+. Please, upgrade your react-native to 0.69+. If you want to keep using react-native < 0.69, please, keep using react-native-flipper 0.162 I wan to highlight that you still can use new versions of Flipper itself! For instance, you should be able to run react-native-flipper@0.162 with Flipper@0.171.1.

Commented On 25 Oct 2022 at 08:47:53

Aigoncharov

started

Started On 24 Oct 2022 at 10:24:51
Issue Comment

Aigoncharov

unhandledrejection: Error: flipper-server: timeout for command 'client-request-response'

🐛 Bug Report

"unhandledrejection" event intercepted: Error: Unable to send, connection error: Error: flipper-server: timeout for command 'client-request-response'

To Reproduce

This issue randomly pops up while using react native app with react-native-flipper package installed. versions - "react-native-flipper": "^0.171.1", "react": "17.0.1", "react-native": "0.64.1",

flipper desktop: "0.171.1" 

Forked On 21 Oct 2022 at 01:06:33

Aigoncharov

Could you try disabling "Flipper Server" in your settings?

Commented On 21 Oct 2022 at 01:06:33

Aigoncharov

started

Started On 20 Oct 2022 at 12:20:38
Issue Comment

Aigoncharov

Plugin build would fail after flipper-pkg-lib migrated to esbuild

Got node_modules/electron/index.js:1:19: ERROR: Could not resolve "fs" and node_modules/electron/index.js:2:21: ERROR: Could not resolve "path" errors after using the newer flipper-pkg-lib.

Same errors would be reproducible after creating a brand new project following the guide here (https://fbflipper.com/docs/tutorial/js-setup/) with npx flipper-pkg init.

Reproducing the errors using node.js 18.8.0 or 14.19.0.

Forked On 18 Oct 2022 at 01:06:14

Aigoncharov

Closed by #4145

Commented On 18 Oct 2022 at 01:06:14
Issue Comment

Aigoncharov

NPM publishing failing - outdated credentials?

Looking at the action to publish to NPM, it's been failing for the last few releases:

error Couldn't publish package: "https://registry.yarnpkg.com/flipper-frontend-core: You do not have permission to publish \"flipper-frontend-core\". Are you logged in as the correct user?"
info Visit https://yarnpkg.com/en/docs/cli/publish for documentation about this command.
Error: Command failed: yarn publish --new-version 0.165.0
    at checkExecSyncError (node:child_process:[84](https://github.com/facebook/flipper/actions/runs/3069500436/jobs/4958229865#step:7:85)1:11)
    at execSync (node:child_process:912:15)
    at publishPackages (/home/runner/work/flipper/flipper/desktop/scripts/workspaces.tsx:210:15) {
  status: 1,
  signal: null,
  output: [ null, null, null ],
  pid: 2458,
  stdout: null,
  stderr: null
}
error Command failed with exit code 1. 

Do the credentials need to be updated? Thanks!

Forked On 18 Oct 2022 at 11:30:01

Aigoncharov

Should finally be resolved https://github.com/facebook/flipper/actions/runs/3272874463/jobs/5384404634

Commented On 18 Oct 2022 at 11:30:01

Aigoncharov

started

Started On 17 Oct 2022 at 09:27:43
Issue Comment

Aigoncharov

GitHub Actions Workflow failed - Publish Android

The workflow Publish Android failed. You can see it at

https://github.com/facebook/flipper/actions/runs/3236169462

Forked On 17 Oct 2022 at 08:28:42

Aigoncharov

It is finally fixed https://github.com/facebook/flipper/actions/runs/3267973679 Thanks @rasaha91!

Commented On 17 Oct 2022 at 08:28:42

Aigoncharov

Upload artifacts to a GitHub release

On 17 Oct 2022 at 08:01:57

Aigoncharov

Remove running ghr

Pushed On 17 Oct 2022 at 08:00:40

Aigoncharov

started

Started On 16 Oct 2022 at 08:34:35